home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / dev-util / dialog-1.0.20050206 / dialog-1.0.20050206.ebuild < prev    next >
Text File  |  2005-12-09  |  1KB  |  39 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.0.20050206.ebuild,v 1.10 2005/07/05 09:36:19 dragonheart Exp $
  4.  
  5. inherit eutils
  6.  
  7. MY_PV="${PV/1.0./1.0-}"
  8. S=${WORKDIR}/${PN}-${MY_PV}
  9. DESCRIPTION="tool to display dialog boxes from a shell"
  10. HOMEPAGE="http://hightek.org/dialog/"
  11. SRC_URI="mirror://gentoo/${PN}_${MY_PV}.orig.tar.gz"
  12.  
  13. LICENSE="GPL-2"
  14. SLOT="0"
  15. KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc x86"
  16. IUSE="unicode"
  17.  
  18. DEPEND=">=app-shells/bash-2.04-r3
  19.     >=sys-libs/ncurses-5.2-r5"
  20.  
  21. src_compile() {
  22.     #export LANG=C
  23.     use unicode && ncursesw="w"
  24.     econf "--with-ncurses${ncursesw}" || die "configure failed"
  25.     emake || die "build failed"
  26. }
  27.  
  28. src_install() {
  29.     make install DESTDIR="${D}" || die
  30.     dodoc CHANGES README VERSION
  31.  
  32.     docinto samples
  33.     dodoc samples/*
  34.     docinto samples/install
  35.     dodoc samples/install/*
  36.     docinto samples/copifuncs
  37.     dodoc samples/copifuncs/*
  38. }
  39.